Newsbin 6.91 B10 Beta - build 5783

This is the place to help test and discuss Version 6 Beta releases.

Newsbin 6.91 B10 Beta - build 5783

Postby Quade » Sat May 18, 2024 10:37 am

It's B10 because B9 never made it out of internal testing but was on IRC.


6.91 B10 5783:
Internal: Scheduler didn't save configuration because the NBI keys were too short.

6.91 B9 5780:
Display: If you pause then add a download, then add a password, the password doesn’t show in properties.
Made it read password and decode path directly from DB and write back directly to DB
Display: Group add window, if nothing was checked in the filters, nothing showed up.
Display: When selecting “Load Special or any of the top three items in the reload combo it triggers a load.
Even though we don’t want to load, we want to wait till a the popup for “Special” finishes.
properties till the download commences.
Display: “Download to Folder Named for Subject will sometimes include”\" char and mess up.
Internal: Significant performance boost from using more modern C++isms. Small file download speed is significantly improved.


https://s3.us-east-1.amazonaws.com/down ... 0-5783.exe
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44905
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin 6.91 B10 Beta - build 5783

Postby FrizzleFry » Tue May 21, 2024 3:46 pm

I keep getting these errors with the new beta:
ERROR news[dot]newshosting[dot]comSSL Lib returned error: 0xffffffffffffdaa0
ERROR Downloader: Socket Exception NEWS SERVER ERROR: NewsHosting Unable to start SSL to news server Error: SSL Negotiation Failed

and I'm unable to download anything.

I do not get the errors on build 5731.
User avatar
FrizzleFry
Seasoned User
Seasoned User
 
Posts: 709
Joined: Sun Oct 09, 2005 12:04 am

Registered Newsbin User since: 05/04/03

Re: Newsbin 6.91 B10 Beta - build 5783

Postby Quade » Wed May 22, 2024 12:01 am

Can you verify the server options?

For example are you using the standard SSL port or something else?

I'm not doubting you. I'm just puzzled. No much about that area has changed.

Was it a normal upgrade install?

If you tell me what settings you've set, not the username or password, I can try the settings here. You can PM them to me if you want.

Are you using XFeatures?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44905
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin 6.91 B10 Beta - build 5783

Postby FrizzleFry » Wed May 22, 2024 2:47 am

I'm using the default SSL port 563.

Not using proxy and nothing in really advanced is checked.

I think it was a normal upgrade install. All my settings came forward.
User avatar
FrizzleFry
Seasoned User
Seasoned User
 
Posts: 709
Joined: Sun Oct 09, 2005 12:04 am

Registered Newsbin User since: 05/04/03

Re: Newsbin 6.91 B10 Beta - build 5783

Postby kenr » Wed May 22, 2024 7:02 am

Still wiping the watch subject with a regex in it, resulting in it downloading EVERYTHING
To test use a regex in a watch, restart and it is gone and everything is downloaded for that specified GoG
User avatar
kenr
Seasoned User
Seasoned User
 
Posts: 325
Joined: Wed Mar 27, 2002 6:14 am
Location: Galashiels

Registered Newsbin User since: 04/13/03

Re: Newsbin 6.91 B10 Beta - build 5783

Postby Quade » Wed May 22, 2024 10:09 am

I'm using the default SSL port 563.


I'll give it a try. Thanks.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44905
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin 6.91 B10 Beta - build 5783

Postby Quade » Wed May 22, 2024 10:16 am

To test use a regex in a watch, restart and it is gone and everything is downloaded for that specified GoG


I can see it now. Thanks. I'll figure out what's up.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44905
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin 6.91 B10 Beta - build 5783

Postby Quade » Wed May 22, 2024 11:58 pm

Got a fix for the RE's. Still trying the SSL.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44905
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin 6.91 B10 Beta - build 5783

Postby Quade » Fri May 24, 2024 10:09 pm

FF, I can't repro it currently. I don't see anything wrong in your config either. I'll make a new version for you to try. Try to add more logging.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44905
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin 6.91 B10 Beta - build 5783

Postby FrizzleFry » Sun May 26, 2024 11:57 am

Ok. I get the same errors in 5775.
User avatar
FrizzleFry
Seasoned User
Seasoned User
 
Posts: 709
Joined: Sun Oct 09, 2005 12:04 am

Registered Newsbin User since: 05/04/03

Re: Newsbin 6.91 B10 Beta - build 5783

Postby Quade » Mon May 27, 2024 7:36 pm

What kind of security software do you run?

How about turning the connections down to 6, restart Newsbin and see if you get the same symptoms?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 44905
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Newsbin 6.91 B10 Beta - build 5783

Postby FrizzleFry » Tue May 28, 2024 1:24 am

Reducing the server connections to 6 had no effect. I still get the same SSL errors.
User avatar
FrizzleFry
Seasoned User
Seasoned User
 
Posts: 709
Joined: Sun Oct 09, 2005 12:04 am

Registered Newsbin User since: 05/04/03

Re: Newsbin 6.91 B10 Beta - build 5783

Postby FrizzleFry » Thu May 30, 2024 3:22 am

As you suggested, disabling security programs solved the SSL errors issue.
User avatar
FrizzleFry
Seasoned User
Seasoned User
 
Posts: 709
Joined: Sun Oct 09, 2005 12:04 am

Registered Newsbin User since: 05/04/03


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 2 guests