Version 6.80 Release Candidate 5 Available...

This is the place to help test and discuss Version 6 Beta releases.

Version 6.80 Release Candidate 5 Available...

Postby dexter » Thu Feb 15, 2018 1:45 pm

Made more changes than we would like being in Release Candidate status but we were getting reports of poor performance when downloading 1000s of single part posts (like picture files) that we decided to address now instead of in a later version. A number of other issues also cropped up that have been addressed.

Changes in this version:
  • Fixed issue where clicking the "X" in download/files list clears search but doesn't clear search drop-down.
  • Fixed issue with Newsbin slowing down when there were 10s of 1000s of small files (like picture files) queued for download.
  • Fixed issue where header based watch lists were losing the groups they came from.
  • Fixed issue where ading a bunch of files (1000s) to the download list would bog things down.
  • Fixed issue processing certain types of posts using non-standard file counter designation.
  • Fixed issue with files not getting marked as downloaded sometimes.
  • Fixed file naming issue when downloading text only posts.
  • Fixed issue with Remote NZB function not defaulting to a proper download and unrar path if they weren't set in the options.
  • Fixed issue with registration introduced in RC4
The full change history and the download link is on the Newsbin Beta Page.

If you find any issues, please reply to this thread or use our Technical Support Contact Form.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9441
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Thu Feb 15, 2018 2:56 pm

This one should solve the issue heavy downloaders reported where Autopar was slow to process the downloaded files after they backlogged.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby triskel » Fri Feb 16, 2018 10:09 am

I have a problem with this RC: after downloading the headers from a group, I check some of them for download, but the download doesn't start.
To start the download I have to close and restart Newsbin, or move headers to "Wish List" and to "Downloading Files" again.
User avatar
triskel
Active Participant
Active Participant
 
Posts: 67
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Fri Feb 16, 2018 10:10 am

Not sure how I can reproduce this. Is it running under Windows?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby triskel » Fri Feb 16, 2018 10:20 am

Yes: Windows 10 1709
User avatar
triskel
Active Participant
Active Participant
 
Posts: 67
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.80 Release Candidate 5 Available...

Postby olog_hai » Sun Feb 18, 2018 11:43 pm

Same here. I'm on Windows 7 Pro x64. Newsbin Pro 6.80RC5 is pretty badly broken for me because it's now very difficult to download files. If I select a range of files from a group or an NZB and right-click and click Download, they stay stuck in Queued. I tried going to the Downloading Files list and selecting some files and clicking Pause, Unpause, and Retry, and nothing works to get them to actually download. The only thing that seems to work is double-clicking one file a time in the group or NZB after the Downloading Files list is cleared. Then they will download one by one.
olog_hai
Occasional Contributor
Occasional Contributor
 
Posts: 16
Joined: Wed Aug 25, 2010 9:56 am

Registered Newsbin User since: 02/01/10

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Mon Feb 19, 2018 7:05 am

The only thing that seems to work is double-clicking one file a time in the group or NZB after the Downloading Files list is cleared. Then they will download one by one.


So you add files and they never end up on the download list? I might delete the "DownloadsV2.db3" files in the data folder and try again. I'd turn on debug level logging in the advanced options and look at the logs too.

I just added 20 gigs to the download list in one shot so, I know it's doable. Your symptoms are different from the Triskel. He's complaining about connections to the server. You seem to have problems getting files into the download list.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby triskel » Mon Feb 19, 2018 7:38 am

My checked files do appear in the "Downloading Files" list, but nothing happens.
If I restart Newsbin (or move the headers in that list to "Wish List" and then to "Downloading Files" again") they are still there but the download starts immediately.
Reinstalled RC4: everything's working fine again.
User avatar
triskel
Active Participant
Active Participant
 
Posts: 67
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.80 Release Candidate 5 Available...

Postby Amsterdammer » Mon Feb 19, 2018 8:55 am

I just installed this version.

When I open it, the Message of the Day window says "Can't Reach This Page."

Also, search (paid) does not work for me.

Listing headers and downloading files works.
User avatar
Amsterdammer
n00b
n00b
 
Posts: 7
Joined: Mon Dec 23, 2013 10:55 am
Location: Amsterdam

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Mon Feb 19, 2018 10:00 am

Typically this means your firewall is blocking Newsbin off the internet. I'd check that because both search and the MOTD are working.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Amsterdammer » Mon Feb 19, 2018 12:04 pm

Quade wrote:Typically this means your firewall is blocking Newsbin off the internet. I'd check that because both search and the MOTD are working.


Both inbound and outbound on the Firewall are set to allow Newsbin -- and until now every update has continued to work normally.

Just in case I have (re)added firewall rules, but the problem persists.

Note: the Stop Search Processing button doesn't stop the search process.

I'm using the correct SSL port and settings according to my Usenet provider, and have no connection problems with my provider.
User avatar
Amsterdammer
n00b
n00b
 
Posts: 7
Joined: Mon Dec 23, 2013 10:55 am
Location: Amsterdam

Re: Version 6.80 Release Candidate 5 Available...

Postby cathaven » Mon Feb 19, 2018 12:45 pm

Amsterdammer wrote:
Quade wrote:Typically this means your firewall is blocking Newsbin off the internet. I'd check that because both search and the MOTD are working.


Both inbound and outbound on the Firewall are set to allow Newsbin -- and until now every update has continued to work normally.


I'm having the same problem. It worked fine up until I installed Build 5042, but now I get "Can't Reach This Page." I don't have the paid search, so no way of checking that.
cathaven
Active Participant
Active Participant
 
Posts: 57
Joined: Sat Nov 30, 2002 7:56 am

Registered Newsbin User since: 04/01/03

Re: Version 6.80 Release Candidate 5 Available...

Postby dexter » Mon Feb 19, 2018 12:51 pm

Often installing a new version of Newsbin can look like a different program to security software and you have to tell it to allow Newsbin out again. We are receiving no other reports of this and have had over 1000 downloads of RC5 so I have to assume it's a local problem. Newsbin needs access to port 443 for both the MOTD and the Search function.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9441
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Amsterdammer » Mon Feb 19, 2018 1:01 pm

dexter wrote:Often installing a new version of Newsbin can look like a different program to security software and you have to tell it to allow Newsbin out again. We are receiving no other reports of this and have had over 1000 downloads of RC5 so I have to assume it's a local problem. Newsbin needs access to port 443 for both the MOTD and the Search function.


Interesting. I just tried port 443, but the problem continues.

I have removed old references to Newsbin from the firewall, and added new rules. The problem persists.

I have also turned off the firewall altogether, with the same result.

Port 563 has worked for me since 'forever,' and I have not run into these issues with any of the previous versions.

I have Windows 10 with the latest updates. All other programs requiring online access are fully functioning.

I guess I'll have to uninstall this RC and reinstall the previous version.
User avatar
Amsterdammer
n00b
n00b
 
Posts: 7
Joined: Mon Dec 23, 2013 10:55 am
Location: Amsterdam

Re: Version 6.80 Release Candidate 5 Available...

Postby cathaven » Mon Feb 19, 2018 1:21 pm

I have Windows Firewall set to notify me if a new program requests access, plus I also tried turning it off altogether. It didn't help. It's not a Firewall issue as far as I can tell. I even tried disabling my anti-virus, but I couldn't see how that would be the problem & I was correct.

For whatever it's worth, I run the latest updated version of Windows 10 32bit. The last problem I had was specific to 32bit Windows.
cathaven
Active Participant
Active Participant
 
Posts: 57
Joined: Sat Nov 30, 2002 7:56 am

Registered Newsbin User since: 04/01/03

Re: Version 6.80 Release Candidate 5 Available...

Postby Amsterdammer » Mon Feb 19, 2018 1:24 pm

cathaven wrote:I have Windows Firewall set to notify me if a new program requests access, plus I also tried turning it off altogether. It didn't help. It's not a Firewall issue as far as I can tell. I even tried disabling my anti-virus, but I couldn't see how that would be the problem & I was correct.

For whatever it's worth, I run the latest updated version of Windows 10 32bit. The last problem I had was specific to 32bit Windows.


I'm on 32 bit as well.
User avatar
Amsterdammer
n00b
n00b
 
Posts: 7
Joined: Mon Dec 23, 2013 10:55 am
Location: Amsterdam

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Mon Feb 19, 2018 1:34 pm

The MOTD and Search use two completely different ways to get onto the internet. Search uses my code, MOTD use IE so, Dex and I are pretty sure your problem is the firewall.

I assume you're not using the MS built in firewall because it defaults to permitting all programs to talk on the internet.

I'll see if I can dig out a 32 bit machine.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Amsterdammer » Mon Feb 19, 2018 1:43 pm

Quade wrote:I assume you're not using the MS built in firewall because it defaults to permitting all programs to talk on the internet.


I use the standard, built in MS Firewall.

I also use Malwarebytes, which I disabled to see whether that program somehow caused the problem.
User avatar
Amsterdammer
n00b
n00b
 
Posts: 7
Joined: Mon Dec 23, 2013 10:55 am
Location: Amsterdam

Re: Version 6.80 Release Candidate 5 Available...

Postby triskel » Mon Feb 19, 2018 1:44 pm

I'm on 64 bit
User avatar
triskel
Active Participant
Active Participant
 
Posts: 67
Joined: Sun Jan 04, 2004 3:39 pm
Location: Europe

Registered Newsbin User since: 11/30/03

Re: Version 6.80 Release Candidate 5 Available...

Postby dexter » Mon Feb 19, 2018 3:22 pm

Amsterdammer wrote:I also use Malwarebytes, which I disabled to see whether that program somehow caused the problem.


Malwarebytes has been known to conflict with Newsbin in the past. When you disabled it did you reboot your machine? A reboot is required to remove any kernel level drivers.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9441
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Amsterdammer » Mon Feb 19, 2018 3:37 pm

dexter wrote:
Amsterdammer wrote:I also use Malwarebytes, which I disabled to see whether that program somehow caused the problem.


Malwarebytes has been known to conflict with Newsbin in the past. When you disabled it did you reboot your machine? A reboot is required to remove any kernel level drivers.


Yes, I rebooted. No difference.

I have now re-installed 6.72 (32 bit), and everything works out of the box.
User avatar
Amsterdammer
n00b
n00b
 
Posts: 7
Joined: Mon Dec 23, 2013 10:55 am
Location: Amsterdam

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Mon Feb 19, 2018 3:54 pm

I'm on 64 bit


How about disabling SSL, restarting Newsbin and seeing if the symptoms change?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Tue Feb 20, 2018 8:21 pm

I have Windows Firewall set to notify me if a new program requests access, plus I also tried turning it off altogether.


I was able to reproduce this on my one-lung 32 bit machine. It's pretty odd. Header downloads work fine but search doesn't even though they use the same networking code. On this same machine, IE works but edge doesn't.

We're still investigating but it looks like an RC6 will be needed.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Amsterdammer » Tue Feb 20, 2018 8:39 pm

Quade wrote:
We're still investigating but it looks like an RC6 will be needed.


Thanks. Meanwhile I'm using the old version. Fantastic program!
User avatar
Amsterdammer
n00b
n00b
 
Posts: 7
Joined: Mon Dec 23, 2013 10:55 am
Location: Amsterdam

Re: Version 6.80 Release Candidate 5 Available...

Postby cathaven » Tue Feb 20, 2018 10:48 pm

I'm happy to use the new version, as I don't subscribe to the search & I'll know when a new version is out through notifications on this thread, so I can live with not automatically getting the message of the day. Also, the link to view the message archive works fine.
cathaven
Active Participant
Active Participant
 
Posts: 57
Joined: Sat Nov 30, 2002 7:56 am

Registered Newsbin User since: 04/01/03

Re: Version 6.80 Release Candidate 5 Available...

Postby Bismark » Wed Feb 21, 2018 11:28 pm

No major problems, but after downloading a few videos with .RAR files, many .RAR files show in the files tab although they are not on the disk and are removed by hitting the "Remove files that are no longer on disk" blue circular arrow. When NB used to process the .RAR files, they were deleted from the files tab.
Bismark
Seasoned User
Seasoned User
 
Posts: 160
Joined: Fri Feb 26, 2010 4:03 am

Registered Newsbin User since: 02/27/10

Re: Version 6.80 Release Candidate 5 Available...

Postby kirm » Thu Feb 22, 2018 9:29 pm

Never thought I would see this issue again, had my cache stuck at 400/400 (16) and just would not budge. Using a couple of previous RC versions did not change a thing. Put it back to RC5 and still stuck. Well went to the import folder and did the same trick as with the old GZ files with the text files. Narrowed the problem down to one group with a spammer hitting this group with like thousands of posts every couple minutes of 2.2 to 2.4 kb files. Newsbin totally choked on this group. I slowly added all the other text files back and then got my headers from all other groups. Worked on the text files with this group (a.b.software) and introduced the stuck files one by one (over 1Gb) of data. Some just would not work at all. I deleted those text files using an unlocker program, then downloaded all updates again, and then another 1000 or so files would come in.

In all my years with using Newsbin, I have not seen this amount of spam coming in. Hope you are not upset with me listing this particular group but can you check this one out. Delete it after reading this maybe. I have it working for now, but have been manually going for updates, and it's like every few minutes, there are thousand more spams coming in. May just have to remove this group. Just never seen anything quite like this in all my years with you.
kirm
Seasoned User
Seasoned User
 
Posts: 225
Joined: Sun Aug 17, 2003 4:17 pm

Registered Newsbin User since: 05/15/03

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Thu Feb 22, 2018 11:09 pm

. Newsbin totally choked on this group.


You can either wait till it finishes, filter out the spammer using a header filter, or purge the TXT of these posts using some other tool.

TeeVee and about 12 other groups are getting hammered with spam. Newsbin is still chunking through the data, it's just going to be slower than normal files. A header filter that blocks all ZIP files for these groups would solve it.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby dexter » Thu Feb 22, 2018 11:14 pm

These are the groups getting spammed:

alt.binaries.amazing
alt.binaries.teevee
alt.binaries.usenetrevolution
alt.binaries.deutsch
alt.binaries.software
alt.binaries.u4e
alt.binaries.pwp
alt.binaries.ghosts
alt.binaries.usenet2day
alt.binaries.etc

If you install a header filter on the poster: "TiMnZb <nzbnewzfrance.com@ssl.local>" then Newsbin will be able to ride through it fine.

Instructions here
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9441
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby kirm » Fri Feb 23, 2018 2:00 am

Thanks guys, been some time since adding a filter. Took me a little effort as I could not get it to work at first, forgot the second part of the properties. Finally getting it to work, I recalled, I used to just add the filter to the global settings filter so never required the second part. It saves the 2 step process. Just filtered spammer using "TiMnZb" till he changes that again.

Thanks for the refresher, my old mind is getting forgetful at times.
kirm
Seasoned User
Seasoned User
 
Posts: 225
Joined: Sun Aug 17, 2003 4:17 pm

Registered Newsbin User since: 05/15/03

Re: Version 6.80 Release Candidate 5 Available...

Postby mjpierce » Sat Feb 24, 2018 10:46 am

MOTD seems to be broken again. Win 7 32bit.

Says "Make sure the web address http:// is correct."

Just like before in https://forums.newsbin.com/viewtopic.php?f=44&t=42850

B11 works fine with zero changes to my PC.
mjpierce
Seasoned User
Seasoned User
 
Posts: 102
Joined: Tue Jun 05, 2007 5:29 pm

Registered Newsbin User since: 10/29/06

Re: Version 6.80 Release Candidate 5 Available...

Postby dexter » Sat Feb 24, 2018 10:57 am

Known issue, will be fixed in the next one. Problem is only with 32 bit systems.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9441
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Sat Feb 24, 2018 12:01 pm

For whatever reason, my devel tools seem to have a hard time making a valid 32 bit program any more. I'm not clear if it's because MS doesn't care about 32 bits anymore or what. If I build 32 and 64 exactly the same way, 32 bits seems to build broken.

I think I'm going to have to turn down/turn off the optimizer (which makes faster code) in 32 bit mode.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby tongueboy » Wed Feb 28, 2018 1:38 am

Ok, no more files ending up in a folder called "missing".
A couple of odd things.
When downloading it appears the groups are trying to refresh but don't, or at least don't appear to be because there are stacks of attempt to download headers from groups that appear to be doing nothing.
Downloading overnight, which is what I usually do, leads to stacks of apparent header downloads in the download list.
But when my downloads finish and I refresh the list it is fast and appears it has been downloading headers.
Never happened before.
Another thing, I have started using an nzb site that is not newznab based but rather based on nzb's that humans upload to the site.
Most times when I try to use newsbin pro to download these it seems as if it doesn't even see the nzb's, However when I load then into the newshosting news reader they download flawlessly except of course posts that have been taken down.
I grab nzb's direct from newsgroups and this site and load them into newsbin and almost always I have to load all the files that newsbin couldn't read into the newshosting reader, which downloads them with no problem.
Using 6.80RC5 build 5042.
Just some feedback for the latest beta and some issues I have encountered.
tongueboy
Occasional Contributor
Occasional Contributor
 
Posts: 48
Joined: Wed Aug 01, 2012 2:07 am

Registered Newsbin User since: 07/27/12

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Wed Feb 28, 2018 9:10 am

I suspect the NZB issue is because of illegal NZB fields in the header. Someone has reported this and I'm working around the issue by simply removing these fields from the NZB from now on. If you want to verify this, edit a non-functional NZB in Wordpad and cut out the line that contains "DOCTYPE" . Then save and try to load again.

Are you using the 32 or 64 bit version
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby slee » Wed Feb 28, 2018 1:35 pm

I've notice since installing this release that the "empty" internet search hasn't been working. I keep getting the same results from 2/27/2018. It's as if the search is frozen in time. I don't know if it's connected to this release or coincidentally with the search engine.
slee
Seasoned User
Seasoned User
 
Posts: 144
Joined: Wed Jan 08, 2003 10:50 pm

Registered Newsbin User since: 05/18/01

Re: Version 6.80 Release Candidate 5 Available...

Postby dexter » Wed Feb 28, 2018 1:52 pm

Are you referring to wildcard? I just tried a blank search and it did perform the wildcard search. You can also put in an asterisk to do the same thing. What are you observing?
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9441
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Wed Feb 28, 2018 1:59 pm

I've notice since installing this release that the "empty" internet search hasn't been working.


Make sure it's not set for "Poster" searching.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Pinion_13 » Wed Feb 28, 2018 4:03 pm

Duplicate detection isn't working for me. It hasn't for several versions now. I just downloaded the same file twice to test. Newsbin put the duplicate in the same folder with a (1) in the filename.
Pinion_13
n00b
n00b
 
Posts: 9
Joined: Sun Apr 27, 2008 5:54 am

Registered Newsbin User since: 04/26/08

Re: Version 6.80 Release Candidate 5 Available...

Postby dexter » Wed Feb 28, 2018 4:11 pm

Are you downloading from NZB files? The duplicate detection is bypassed for nzb autoload and when using the nzb automation interface.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9441
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby slee » Wed Feb 28, 2018 4:17 pm

Quade wrote:Make sure it's not set for "Poster" searching.


It was set for "Subject", but it's now working. Maybe restarting Newsbin for the third time was the trick. Anyways, thanks for the fast response. Newsbin = Greatness, Support = Even better. :-)
slee
Seasoned User
Seasoned User
 
Posts: 144
Joined: Wed Jan 08, 2003 10:50 pm

Registered Newsbin User since: 05/18/01

Re: Version 6.80 Release Candidate 5 Available...

Postby dexter » Wed Feb 28, 2018 4:30 pm

Actually there was an issue with the server. It's catching up now but some current results are already available. It'll be back to normal in the next 30-60 minutes.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9441
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby tongueboy » Wed Feb 28, 2018 7:55 pm

Quade wrote:I suspect the NZB issue is because of illegal NZB fields in the header. Someone has reported this and I'm working around the issue by simply removing these fields from the NZB from now on. If you want to verify this, edit a non-functional NZB in Wordpad and cut out the line that contains "DOCTYPE" . Then save and try to load again.

Are you using the 32 or 64 bit version


Thanks, I'll try. I am using 64 bit version.
Oddly enough I tried downloading one from the site with newshosting today and it appeared to download but was all messed up and newsbin is downloading it fine.
tongueboy
Occasional Contributor
Occasional Contributor
 
Posts: 48
Joined: Wed Aug 01, 2012 2:07 am

Registered Newsbin User since: 07/27/12

Re: Version 6.80 Release Candidate 5 Available...

Postby Pinion_13 » Wed Feb 28, 2018 8:03 pm

dexter wrote:Are you downloading from NZB files? The duplicate detection is bypassed for nzb autoload and when using the nzb automation interface.


Is that a recent change? I've been using nzbs for years and I've only noticed duplicate detection not functioning fairly recently. Is loading nzbs from chrome different from firefox?
Pinion_13
n00b
n00b
 
Posts: 9
Joined: Sun Apr 27, 2008 5:54 am

Registered Newsbin User since: 04/26/08

Re: Version 6.80 Release Candidate 5 Available...

Postby tongueboy » Wed Feb 28, 2018 8:15 pm

Quade wrote:I suspect the NZB issue is because of illegal NZB fields in the header. Someone has reported this and I'm working around the issue by simply removing these fields from the NZB from now on. If you want to verify this, edit a non-functional NZB in Wordpad and cut out the line that contains "DOCTYPE" . Then save and try to load again.

Are you using the 32 or 64 bit version


Also with header download stacks appearing in the download pane I get a stack of messages in red that say "display update pending", but no errors in the logging pane.
tongueboy
Occasional Contributor
Occasional Contributor
 
Posts: 48
Joined: Wed Aug 01, 2012 2:07 am

Registered Newsbin User since: 07/27/12

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Thu Mar 01, 2018 10:17 am

Also with header download stacks appearing in the download pane I get a stack of messages in red that say "display update pending", but no errors in the logging pane.


It might be time for some cleanup then. I'm not having any of these issues at the moment. Maybe "Open Data Folder" from the options, close Newsbin, then delete "DownloadsV2.db3" and "Downloaded.db3". This will wipe the download, wish and failed lists. Downloaded.db3 is the files list.

DownloadMarker.db3 is what tags things as "downloaded". If it gets too big things could slow down too.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby tongueboy » Thu Mar 01, 2018 11:42 pm

Quade wrote:I suspect the NZB issue is because of illegal NZB fields in the header. Someone has reported this and I'm working around the issue by simply removing these fields from the NZB from now on. If you want to verify this, edit a non-functional NZB in Wordpad and cut out the line that contains "DOCTYPE" . Then save and try to load again.

Are you using the 32 or 64 bit version


I tried that and newsbin still will not see it as an nzb but newshosting will still download it even after deleting that line and saving it.
I can post the text version of the nzb if you like but it is rather long and I don't want to take up space if it is not necessary.
tongueboy
Occasional Contributor
Occasional Contributor
 
Posts: 48
Joined: Wed Aug 01, 2012 2:07 am

Registered Newsbin User since: 07/27/12

Re: Version 6.80 Release Candidate 5 Available...

Postby tongueboy » Wed Mar 07, 2018 3:21 am

Quade wrote:
Also with header download stacks appearing in the download pane I get a stack of messages in red that say "display update pending", but no errors in the logging pane.


It might be time for some cleanup then. I'm not having any of these issues at the moment. Maybe "Open Data Folder" from the options, close Newsbin, then delete "DownloadsV2.db3" and "Downloaded.db3". This will wipe the download, wish and failed lists. Downloaded.db3 is the files list.

DownloadMarker.db3 is what tags things as "downloaded". If it gets too big things could slow down too.


This is a partial text file of an nzb that worked fine in the newshosting reader but that newsbin would not recognize as an nzb.
It is long but I hope it might help.
Had to cut some out as it exceeded the character limit.

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE nzb PUBLIC "-//newzBin//DTD NZB 1.0//EN" "http://www.newzbin.com/DTD/nzb/nzb-1.0.dtd">
<nzb xmlns="http://www.newzbin.com/DTD/2003/nzb">


Edited - Quade.
tongueboy
Occasional Contributor
Occasional Contributor
 
Posts: 48
Joined: Wed Aug 01, 2012 2:07 am

Registered Newsbin User since: 07/27/12

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Wed Mar 07, 2018 9:01 am

You can email the NZB to ts@newsbin.com. I'll try it. RC6 is really close and has some NZB Fixes. I'd like to test your NZB Against it before it hits the forum.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Re: Version 6.80 Release Candidate 5 Available...

Postby Quade » Thu Mar 08, 2018 12:31 pm

I got an email for a NZB, I think it was yours. I drag and dropped it onto RC6 and it downloaded fine.

So, it's probably fixed or how we download is different. If you download this type of NZB a bunch, you need to make sure each NZB goes to a unique folder. The reason is the filenames for all of these are the same internally so if multiple download into the same folder, you might get unrar or repair failures.

Make sure $(NZBFILE) is part of the download and unrar path.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43312
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97


Return to Newsbin Version 6 Beta Support

Who is online

Users browsing this forum: No registered users and 5 guests

cron