groups problem, after wine upgrade

While it isn't officially supported, we have many users who successfully run NewsBin under Linux with a Windows emulator (Wine is the most popular). This forum exists for you Linux guys to share your experience getting NewsBin running on Linux as well as report any strangeness that we may or may not be able to fix. DThor is the resident expert.

Moderators: Quade, dexter, newsraider, DThor

groups problem, after wine upgrade

Postby newsraider » Sat Feb 24, 2007 2:31 am

i did a update to wine recently and ever since i cannot open my groups folder. im using 5.2 on this computer. anyone else have this problem?

things were working just fine until i did the update. should i go back to the older version of wine maybe?
User avatar
newsraider
Seasoned User
Seasoned User
 
Posts: 221
Joined: Fri Dec 31, 2004 5:57 am

Registered Newsbin User since: 02/13/06

Postby richy99 » Sat Feb 24, 2007 9:23 am

either try a newer version of newsbin or the older version of wine
User avatar
richy99
Elite NewsBin User
Elite NewsBin User
 
Posts: 6353
Joined: Fri Nov 21, 2003 8:04 pm
Location: Wales

Registered Newsbin User since: 12/31/03

Postby DThor » Sat Feb 24, 2007 11:19 am

Wine release? Unless you're using an overnight build for developers the problem you describe is likely not wine per se, although obviously the upgrade triggered it. I'm suspecting something in the reg or nbi config got munged, so downgrading wine probably won't help(altho definitely try it if all else fails). Just double check your DATA path and verify against where your spools are stored. I've only ever had troubles like you describe when the NB config gets mussed. Check things like where the user app files are stored - there's always been something screwy with that - c_drive/windows/profiles is one place it's kept, which doesn't necessarily map nicely to the paths NB expects.

NB is fairly robust in dealing with spools - it just needs to be pointed to the correct directory, and as long as the server name is *precisely* the same, it will find those rv2 files.

DT
V6 Troubleshooting FAQ . V6 docs. Usenet info at Usenet Tools. Thanks!
User avatar
DThor
Elite NewsBin User
Elite NewsBin User
 
Posts: 5943
Joined: Mon Jul 01, 2002 9:50 am

Registered Newsbin User since: 04/01/03

Postby Quade » Sat Feb 24, 2007 11:26 am

Good point Dthor. Actually I probably know what the problem is. Try looking for a double-thick column on the left side top. Pull it open. More than likely the groups list is in a hidden tab.
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43180
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Postby newsraider » Sat Feb 24, 2007 5:57 pm

i am using wine 0.9.31

Image


i looked through my newsbin files and everything seems to be pointing on the right direction. is there 1 newsbin config file that works with the groups area more directly that i should be looking at closer?

one thing i do is make the datapath the same as my download path. been doing this for a while and never had any problems.

just a note i did a new install of newsbin 5.33 and wine today on another computer and does the same thing. except in 5.33 there are the example groups and the folders are opened, but i cannot close them? all it will do is started downloading the headers when i keep clicking on them.
User avatar
newsraider
Seasoned User
Seasoned User
 
Posts: 221
Joined: Fri Dec 31, 2004 5:57 am

Registered Newsbin User since: 02/13/06

Postby Quade » Sat Feb 24, 2007 9:28 pm

I absolutely don't know what you just said here. I see a groups tab which means it's working. I see nothing wrong in your image. You can't close the groups tab.

Did you try clicking on the plus sign?
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43180
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Postby newsraider » Sun Feb 25, 2007 12:32 am

i know it kinda hard to explain, but when i click on the plus or minus it does nothing. so i can't get to my actual groups to download them because they are in the folder which is closed.

the new install i did the groups folder was open, so you can get to the actual group to download headers, but you can't close the groups folder with the plus and minus.
User avatar
newsraider
Seasoned User
Seasoned User
 
Posts: 221
Joined: Fri Dec 31, 2004 5:57 am

Registered Newsbin User since: 02/13/06

Postby newsraider » Sun Feb 25, 2007 12:39 am

is there a file that i can edit which will open the groups folder and keep them that way?
User avatar
newsraider
Seasoned User
Seasoned User
 
Posts: 221
Joined: Fri Dec 31, 2004 5:57 am

Registered Newsbin User since: 02/13/06

Postby dexter » Sun Feb 25, 2007 1:01 am

That's pretty strange, it points to something else being wrong if you can't get your Unsorted folder to expand by hitting the + sign.

You can try to force it by going into your .nbi file and set "IsExpanded" to 1 under the [Unsorted] section.
User avatar
dexter
Site Admin
Site Admin
 
Posts: 9415
Joined: Fri May 18, 2001 3:50 pm
Location: Northern Virginia, US

Registered Newsbin User since: 10/24/97

Postby newsraider » Sun Feb 25, 2007 1:30 am

great the edit of the nbi worked :D

the folder was opened when i opened newsbin again, but i couldn't close the folder. which i don't really care about doing anyway.

like i said before the only thing that changed was i updated wine. everything else works fine with newsbin.

thanks dexter :)
User avatar
newsraider
Seasoned User
Seasoned User
 
Posts: 221
Joined: Fri Dec 31, 2004 5:57 am

Registered Newsbin User since: 02/13/06

Postby DThor » Sun Feb 25, 2007 11:02 am

Just to clarify, though - just because that folder was closed, doesn't mean nothing works in there unless you manually deactivated them at some point. You just select "Unsorted" and load or whatever - I use GOGs all the time on wine.

As far as the expand issue, when I get back to a linux platform I'll try that - to be honest I haven't done that for quite some time so perhaps there is a wine issue there with the latest.

DT

[EDIT] - Naw, works fine here - I can open/close Gogs, select individual groups, enable/disable them, dbl click to load, drag/drop - the works. Not sure what was going on with your results.
User avatar
DThor
Elite NewsBin User
Elite NewsBin User
 
Posts: 5943
Joined: Mon Jul 01, 2002 9:50 am

Registered Newsbin User since: 04/01/03

Postby newsraider » Sun Mar 04, 2007 1:52 am

hmmm well i don't know what i did then?

i updated to wine 0.9.32 and nothing changed still can't close or open the folder.

oh well everything else works fine and i can access my groups just fine now, so i can live it. im sure next time i reinstall my os it will be back to normal. i think i tinker with stuff too much :roll:
User avatar
newsraider
Seasoned User
Seasoned User
 
Posts: 221
Joined: Fri Dec 31, 2004 5:57 am

Registered Newsbin User since: 02/13/06

Postby Quade » Sun Mar 04, 2007 2:07 am

You know it's not really a tree control right? It's a faked up tree control using a list control. Expansion when you click the "+" is a purely manual thing where I simply add the children to the list with an icon that makes is look indented. As long as "hittest" works to let me know the + has been clicked on, it should just work.

It just occured to me that I know how to make the indent work for real now so, I can do multi-level nesting (if I choose to).
User avatar
Quade
Eternal n00b
Eternal n00b
 
Posts: 43180
Joined: Sat May 19, 2001 12:41 am
Location: Virginia, US

Registered Newsbin User since: 10/24/97

Postby newsraider » Sun Mar 04, 2007 2:32 am

:lol: yep that worked. i didn't even think of that? im so used to just clicking on it with the mouse.

thanks Quade
User avatar
newsraider
Seasoned User
Seasoned User
 
Posts: 221
Joined: Fri Dec 31, 2004 5:57 am

Registered Newsbin User since: 02/13/06


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest